
Computer Animation I    
Final Project Milestones 3-6: Reviews  
 
The remaining four project milestones are all in-class reviews, where we will critique your in-progress work 
in class to help you better achieve your original goals. Here is the schedule in brief:  
 
MILESTONE 3 (model review) Monday April 7th in class 
MILESTONE 4 (rough film) Wednesday April 16th in class 
MILESTONE 5 (lighting/shading review) Wednesday April 23rd in class 
MILESTONE 6 (final film review) Wednesday April 30th in class 
 
As you can see, we’ve got one in-class review each week. The details of each are on the following pages. 
 
It is CRITICAL that you follow the hand-in guidelines closely for each milestone and have your work in the 
handin folder 15 minutes BEFORE class. With 20+ projects to review, we won’t have time to dig around for 
files. 
 
 

GENERAL PROJECT MANAGEMENT/MILESTONE TIPS 
 
Start by creating a project folder for your final project. Inside, give it a subfolder called “scenes.” Put all of 
your final models into that folder as you build them and name them appropriately. AFTER milestone 3: 
 
Build a template scene that you will use to create all of the scenes in your film. Here’s how you do it: 

• Open Maya, set your project folder to your new project folder. 
• Create a REFERENCE to each of your models (File->CreateReference). You should open the 

options box, and within that do Edit->Reset Settings to make sure you have good referencing 
defaults. BE CAREFUL with references! You don’t want to change hierarchies if you can help it. 
Just treat referenced objects as animation-only objects. If you need to make a model fix, go back to 
the referenced scene file itself and make it. 

• Move your objects around to build a reasonable default scene. This is so you don’t have to do it in 
every scene file. 

• Make a new camera with the proper aspect ratio, and position it in a sensible default location. 
• Set the resolution (Windows->Rendering Editors->Render Settings->Common->Image Size) and 

the frame rate (Maya->Preferences->Settings->Time) to match your proposal. 
• Save this scene, named accordingly (“perryTemplate.ma”). 

 
Duplicate your template scene as many times as you have shots in your movie. 
 
For milestones 4 and 6: when you make playblasts to hand in, make them of the appropriate spatial resolution 
(640x?) for each of your shots. Save them out as “shot1.mov” and so on. 
 
Using QuickTime Pro (Edit->Cut and Edit->Paste), you can edit the playblasts together into a coherent 
movie file. When you’re done, save that movie file as a SELF-CONTAINED MOVIE. This means the file 
you make won’t reference any of the playblasts, instead, it will be its very own movie. 
 
The self-contained movie is the ideal thing to hand in for full-film reviews. Name it accordingly 
(“PerryM4.mov”) and put it in the appropriate place. Use a codec that keeps the movie file sizes reasonably 
small, something like H.264.  
 
If you hand in a single movie file, ALWAYS MAKE SURE THE MOVIE IS SELF-CONTAINED. To be 
extra careful, copy your self-contained movie to another machine and try double-clicking it there. If it plays, 
it’s probably self-contained. 
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MILESTONE 3 (model review) 
 
The best thing to hand in for model review is a single Maya ASCII (.ma) file that contains all of your models. 
The template file mentioned in the “general tips” section, above, would be great. Bringing your objects 
together into one scene is important because they may need to be scaled relative to each other anyway. 
 
This milestone is about having animation-ready objects. Here’s a brief checklist (for all of your objects) that 
gets at what this actually means: 
 

• Is the object well-designed? Does it look like it’s supposed to look? 
• Is the object named appropriately? 
• Is the geometry well built? In other words, do you have an appropriate density of faces given the 

object’s purpose in the film? Does the model look good from all appropriate viewpoints? 
• Has it been assigned a basic surface color for easy interactive use in Maya (go ahead and make the 

proper shaders for it if you have time – it’s easier to do now than later)? 
• (animating objects) Does the rig work? Are the pivots in the proper places? TEST IT! 
• (animating objects) Have you locked/hidden the attributes you don’t want to animate? 

 
We will look at as much of your stuff as time permits, starting with the most important model to the film and 
working our way down in priority. We'll be looking at this very checklist, so please heed it.  
 
I encourage you all to do the Maya Polygonal Modeling tutorials and read/skim the relevant chapter of the 
online Maya pdf manual ("Modeling Polygons") to supplement what you already know. I also have a number 
of tutorial DVDs that I can loan you. 
 
Here are some useful things that we may or may not have covered yet in class: 
 
Image Planes Created in the Environment sub-menu of the camera attribute editor. Useful 

for visual reference while modeling. 
Pivot Points Set appropriate pivot points for all of your objects. Select the object, then 

the move tool, then hit Home. Hit Home again when done (or, as we saw in 
class, select the move tool and hold down “d” to move the pivot). 

Changing Selection Type Hold down the right mouse over an object and move to either vertex, edge, 
face, or object. Sometimes you can get stuck; try switching tools and right-
clicking again over the object. 

Modifying Selections Hold down shift while left-clicking/dragging to extend a selection or toggle 
the state of an already selected vertex/edge/face/object. 

Construction History MIGHT be useful for you. When you have an object selected, open the 
attribute editor and examine the tabs at the top. Some of these tabs are from 
the poly modeling tools and may have variable parameters. Use with 
caution. 

Combine Under Polygons menu. With multiple, separate objects selected, this 
command unites them into a single polygonal object. 

Group Under Edit menu. Groups multiple selected objects under a shared parent. 
Useful for encapsulating multiple primitives under one hierarchy node. 

Freeze Transformations Modify->Freeze Transformations. For zeroing-out scale, rotation, or 
translation values prior to using in a hierarchy. Scale is the most important 
to deal with. 

Expressions Window->Animation Editors->Expression Editor. For mathematically 
relating one channel to another. 
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MILESTONE 4 (rough film) 
 
Before you begin to prep for this review, fix and finish your models based on comments from class. Then, 
assemble your shot(s) (look again at the “general tips” section, above) and begin animating!  
 
In this review you will be showing us your entire movie, in rough form. No lighting or shading, just 
playblasts. This milestone is primarily about staging and timing. At a minimum, what we're looking for is 
called "blocking," namely, roughed-in animation on the root nodes of your hierarchies. Blocking should 
communicate the basics of your scene to the audience, such as how long a shot is, where we're supposed to 
look, and how much time passes between key actions in the scene. Blocking starts with the root node and 
sometimes doesn't move past it. Blocking also involves the choice of camera, focal length, etc. 
 
GO BEYOND BLOCKING IF YOU CAN. Many of you have animation-heavy films and better be doing 
more than just blocking for this milestone. The blocking step is a minimum – go ahead and work as much as 
possible beyond that. 
 
Hand in a playblast movie file for EACH OF YOUR FILM'S SHOTS. Those of you with only one shot, 
obviously, will hand in only one movie file. Though it is not required, it would expedite our viewing (and be 
more useful to you as well) if you could edit them together into a single movie (using QuickTime Pro’s cut 
and paste, then “save self contained”). 
 
Helpful hints: 
 

• Create a Maya scene file for each one of your shots. Use a stopwatch to estimate the frame length of 
each scene and set it accordingly (on either side of the time slider). But make sure the frame rate is 
set properly first! 

• Before you import any of your objects into a blank scene, make sure your camera attributes and 
render global settings reflect the resolution you chose. Also make sure you’re looking through the 
proper camera (don’t use persp, use a new camera instead so persp can be used for arbitrary views). 

• Always use incremental save (under File->Save Scene []). Files get corrupted all the time and you 
don't want to lose all of your work. 

• Make playblasts to evaluate your motion, as always (the "play" button is unreliable). 
• Change the basic colors of your objects if we can't see them clearly in the render. The whole 

point of these reviews is that we can see your motion! And you should have done this at the 
modeling step anyway. 

• Re-read the 1987 Lasseter article (in the hand-outs folder on Course Storage). 
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MILESTONE 5 (lighting/shading review) 
 

First, revise your cameras and motion based on the comments you received in class. As you are animating 
during the remaining weeks, you’re also going to have to contend with shading and lighting. That’s what this 
milestone is about. 
 
For this milestone you are to hand in 3-8 full-resolution (640x?), production-quality rendered still images 
(TIFF format, please. NOT IFF!) from your final project. Name them appropriately ("PerryShot1.tif" and so 
on). It’s best if the images you hand in cover the range of views in your film so that you’re sure to address 
the lighting and shading needs for the whole film. 
 
Lighting without reference imagery is a bad idea. Return to the image(s) you found and/or made back when 
you proposed the project and seek out more reference sources if you like. The more the better. 
 
Some helpful reminders about lighting: 
 

• Start with the key light for the scene. Translate and rotate the key light based on where you want the 
highlights and the shadows to land in your scene. Get the intensity right and deal with the color later. 

• Spotlights are a great to use because you can look through them. This makes it easy to position the 
shadows they cast. 

• Tackle fill, rim, and bounce lights only after you're confident with your settings for the key. 
• Fill lights are intended to fill in the shadowed areas left dark by the key. They should therefore 

probably not have a specular component, and shouldn't cast shadows either. 
• Rim lights are great for lifting objects out from the background and accentuating their shape. Turn 

the rim intensity up to an absurd number to get the positioning right, then sneak it back down to 
something reasonable. Rim lights generally live on the opposite side of the object from the camera, 
and they point almost directly towards the camera. 

• Bounce lights can be added to try and simulate diffuse inter-reflections between objects. If you want 
to have a bright object next to another object in your scene, you may want a bounce light. 

  
Remember that we use light to: 
 

• Direct the viewer's eye, 
• Communicate where and when, 
• Enhance mood, atmosphere, drama, 
• Reveal character personality, 
• and create depth. 

 
And some other tips: 
 

• Copy your latest animation scene file ("PerryShot1.ma") to an entirely new name for lighting 
("PerryShot1_lighting.ma") BEFORE adding any lights. This ensures that if your file goes bad you 
can still salvage your animation from your old animation file. 

• Once you’ve set up lights in one scene, select them, do Export Selected, and save the lights in a 
difference scene file. Then, reference this new file back in to the original. Reference your lighting rig 
in any scenes that need it. 

• It’s often easy to use full-valued colors for your lights. Set the brightness of the light with the 
"intensity" option, not the color. 

• Try to avoid using an R, G, or B value of 0 when choosing colors, unless you are going for a specific 
special effect. 
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MILESTONE 6 (final film review) 
 
Your final hand-in should include: 
 

1. A full-resolution (640x?) MOVIE (see milestone 2 sheet for resolution options), rendered at 
production quality. When you finally export the movie, use the H.264 codec (at High or Best quality) 
in QuickTime Pro. 

 
Please use care to hand in only one copy of your movie (i.e., don’t hand in the individual rendered scenes 
AND the final compiled QuickTime movie - that’s redundant). 

 
2. A COMPLETE PROJECT FOLDER with all of your objects, scenes, and textures (if you have any). 

 
Again, please clean up your project folder before handing it in. I don’t want every incrementally saved 
version of your scene files, etc. 

 
I will accept the digital data online (in the hand-ins folder), or burned onto a CD/DVD-R. 
 
MAKE SURE your movie is the proper size and plays properly in QuickTime Player before handing it in. 
 
Don’t forget that RENDERING TAKES TIME. Do what you can to render as soon as possible. 
 
Please also hand in your original final project proposal with the final movie. 


